Securly Outage

Incident Report for St Vrain Valley Schools

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 10:54 MDT

Investigating

We are currently investigating an outage with our content filter provider, Securly. As a result, devices are currently in a CIPA compliance mode.
Posted Oct 28, 2025 - 10:29 MDT
This incident affected: Other.